Opened 3 years ago

Closed 3 years ago

#17525 closed Bug (invalid)

Fixes for django.contrib.auth tests

Reported by: andrey@… Owned by: nobody
Component: contrib.auth Version: 1.4-alpha-1
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Found two bugs in my application:

  1. If any of my middleware works with session, test_session_not_accessed fails.
  2. (not a bug really) I use jinja in my project and form.as_ul returns method object. If you can change {{form.as_ul}} to {{form}} tests will also work with jinja2.

Attachments (1)

django.diff (1.3 KB) - added by andrey@… 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by andrey@…

comment:1 Changed 3 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

it was better to fix coffin

Note: See TracTickets for help on using tickets.
Back to Top