Opened 4 years ago

Closed 4 years ago

#17501 closed Bug (duplicate)

Json serialization and ugettext_lazy

Reported by: lars.solberg@… Owned by: nobody
Component: Core (Serialization) Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The json serializer will fail creating a json text when using ugettext_lazy objects.
This is something DjangoJSONEncoder should handle.

See the attached file for a git diff patch file.

Its quite easy to fix, and I guess the fix demonstrate how the DjangoJSONEncoder should be coded..

Attachments (1)

fix.patch (867 bytes) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by anonymous

comment:1 Changed 4 years ago by jakul

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #5590 and #5868. In 5590#comment:6 lukeplant (core developer) states that it is up to clients to implement this code, not Django.

Note: See TracTickets for help on using tickets.
Back to Top