Opened 9 years ago

Closed 7 months ago

#17344 closed New feature (duplicate)

A away to tell ManyToManyField to use ordering on intermediate field

Reported by: FunkyBob Owned by: nobody
Component: Database layer (models, ORM) Version: 1.3
Severity: Normal Keywords: m2m, ordering
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Similar to #11850, it would be good to have a way to mark on a M2M field to use the ordering of the intermediary table.

See patch attached to #11850 for test.

Change History (2)

comment:1 Changed 9 years ago by Aymeric Augustin

Triage Stage: UnreviewedAccepted

comment:2 Changed 7 months ago by Baptiste Mispelon

Resolution: duplicate
Status: newclosed

Even though this ticket is older, I'm going to close it as a duplicate of #30460 which has a pull request attached and some discussion with regards to backwards compatibility.

Note: See TracTickets for help on using tickets.
Back to Top