Code

Opened 2 years ago

Closed 2 years ago

#17331 closed Bug (duplicate)

Django is unable to look for fixtures in zipped egg files.

Reported by: rfkrocktk@… Owned by: nobody
Component: Uncategorized Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I had an interesting thing happen recently when deploying my project (http://github.com/rfkrocktk/django-locality) to PyPI. When I installed it using setuptools, Django couldn't see any of the initial data fixtures I provide in my project. After scratching my head about it for a while and trying to debug it, I found that Django wasn't able to find it because it was in a zipped egg file. I was able to work around this by setting 'zip_safe' equal to 'False' on my module, but it's still kind of confusing and can be frustrating to work with. Would it be possible to patch Django to allow it to search for fixtures inside of zipped egg files?

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Django relies on filesystem paths to load fixtures, translations, templates, static files, and probably a few other things.

While the problem might be solvable for fixtures, I don't think we can teach gettext to look for translations within an egg. This would also be extremely messy for static files.

So this ticket is essentially a duplicate of #596.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.