Opened 4 years ago

Closed 4 years ago

#17282 closed Bug (fixed)

Request path containing %E3 drops server

Reported by: byashimov@… Owned by: nobody
Component: HTTP handling Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


Tried make request with %E3 in path, here is what I've got on dev server:

Traceback (most recent call last):

  File "C:\Python26\lib\site-packages\django\core\servers\", line 283, in run
    self.result = application(self.environ, self.start_response)

  File "C:\Python26\lib\site-packages\django\contrib\staticfiles\", line 68, in __call__
    return self.application(environ, start_response)

  File "C:\Python26\lib\site-packages\django\core\handlers\", line 264, in __call__
    logger.warning('Bad Request (UnicodeDecodeError): %s' % request.path,

UnboundLocalError: local variable 'request' referenced before assignment

Not only windows. Also tested on fastcgi and uwsgi - drops both.

Change History (2)

comment:1 Changed 4 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Reqaest path containing %E3 drops server to Request path containing %E3 drops server

comment:2 Changed 4 years ago by lukeplant

  • Resolution set to fixed
  • Status changed from new to closed

Essentially a dupe of #15672, and already fixed in [15918]

Note: See TracTickets for help on using tickets.
Back to Top