Opened 4 years ago

Closed 4 years ago

#17247 closed Bug (duplicate)

`django.contrib.auth` tests fail with non english localisation

Reported by: rabio Owned by: nobody
Component: contrib.auth Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


When I run all tests on my project with test many tests from contrib.auth failed due to not expecting hardcoded english strings in rendered context instead of localised texts.

Attached patch solved that problem for me.

I'm using there a kind of a poor man escaping filter. It probably should be substituted with one from template framework, though.

Attachments (1)

fix-auth-tests-localization.diff (11.9 KB) - added by rabio 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by rabio

comment:1 in reply to: ↑ description Changed 4 years ago by rabio

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, I missed #17194 which this ticket is duplicate of.

Note: See TracTickets for help on using tickets.
Back to Top