Code

Opened 2 years ago

Closed 22 months ago

Last modified 22 months ago

#17121 closed Bug (worksforme)

New documentation version chooser doesn't work in Firefox

Reported by: varikin Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: yes
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In the new thing at that the bottom of the documentation page to switch between the doc version, the other versions that display when hovering disappear before being able to click them in Firefox.

I tested this in chrome and they still show, but in Firefox (I am running Nightly which if FF10) on a Mac, the other options like 1.1, 1,2, 1.3, or Dev disappear shortly after moving the mouse away from the main box saying which version is displayed.

I haven't tested in current stable Firefox though.

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by charettes

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I cannot reproduce using nightly 10.0a1 cc66accc8181 build (most up-to-date as of 10/26/2011) on ubuntu 11.10 x64.

Do you have the most up-to-date version?

comment:2 Changed 2 years ago by carljm

  • Triage Stage changed from Unreviewed to Accepted

I've seen this issue, but it's transient, even on affected versions of Firefox (presuming there are not-affected versions). It has to do with Firefox's "link destination" popup trying to jump over to the right side of the screen, and causing Firefox to think you're no longer hovering over the documentation version links (or something along those lines). I can reproduce it much more reliably if I hit Ctrl-F so the Find bar is present at the bottom of the page. I'm running Firefox 7.0.1 on Ubuntu 10.10 x64, not a FF nightly or anything like that.

comment:3 Changed 2 years ago by varikin

I just checked it at home on FF 7.0. It is the find bar at the bottom (cmd-F/ctr-F) that does it. Closing that bar fixes the issue. Opening again introduces the issue again. Wow! I would love to know what is different that the bar does that.

comment:5 Changed 22 months ago by timo

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this at this point, and it seems to me this would be a bug in Firefox itself and not something we'd fix in the docs.

comment:6 Changed 22 months ago by varikin

  • Needs documentation set

I think it was an issue with that version of Firefox because I can't reproduce it anymore.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.