Opened 5 years ago

Closed 8 months ago

#17082 closed Cleanup/optimization (fixed)

contrib.auth html should be updated to used HTML5 features where possible

Reported by: David Evans Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords: html5
Cc: d@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description


Attachments (1)

ticket17082.diff (1.0 KB) - added by David Evans 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by David Evans

Attachment: ticket17082.diff added

comment:1 Changed 5 years ago by David Evans

Has patch: unset

Ah, ignore moronic patch; and forgive me for creating tickets when not really concentrating! Obviously autofocus attribute needs to be on the input, not the label, which requires slightly deeper patching.

comment:2 Changed 5 years ago by Preston Holmes

Summary: Login form should use HTML5 autofocus with JavaScript as fallbackcontrib.auth html should be updated to used HTML5 features where possible
Triage Stage: UnreviewedAccepted

This would be part of a larger project of updating html in contrib.auth - and unlikely to be fixed in isolation. A similar effort would also exist for contrib.admin (which need not be coupled to the change for auth, as it is much bigger). Such changes need to be backwards compatable, but my understanding of HTML5 is that this is relatively builtin by design.

note: original summary:

Login form should use HTML5 autofocus with JavaScript as fallback

comment:3 Changed 5 years ago by Claude Paroz

Keywords: html5 added

comment:4 Changed 8 months ago by Claude Paroz

Resolution: fixed
Status: newclosed

The autofocus stuff has been basically fixed in [d638cdc42acec608c1].

Note: See TracTickets for help on using tickets.
Back to Top