Opened 4 years ago

Closed 4 years ago

#17010 closed Uncategorized (invalid)

unittest2 conflicted with nosetest

Reported by: fangzhouxing@… Owned by: nobody
Component: Uncategorized Version: 1.3
Severity: Normal Keywords: unittest2
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by russellm)

I use nosetest version 1.0.0. I have to change the source code of Django to make nosetest run:

C:\Python25\Lib\site-packages\django\test\ line 243 changed to :

import unittest
class TransactionTestCase(unittest.TestCase):

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Marking invalid, because you have proposed a solution without describing the actual problem. On top of that, the solution you propose will break other features in Django, because importing unittest as you suggest won't return the library required.

Feel free to reopen this ticket if you want to provide a clear set of instructions for reproducing the problem you are seeing. If you want to propose a solution, that's fine, but we aren't going to apply a patch without a clear understanding of what it is the patch is trying to achieve, and why.

Note: See TracTickets for help on using tickets.
Back to Top