Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17004 closed Bug (needsinfo)

transaction.commit_manually decorator masks exceptions

Reported by: msoulier@… Owned by: nobody
Component: Database layer (models, ORM) Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If I put a commit_manually decorator on a piece of code, and that code raises an exception that isn't caught, all the developer will see is a failure to commit or rollback the transaction, instead of the actual exception that caused the problem.

This can hinder troubleshooting at a customer site.

Is it feasable for the decorator to check for an exception before inadvertently swallowing it, and reporting it?

Thank you.

Change History (2)

comment:1 Changed 4 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to needsinfo
  • Status changed from new to closed

There isn't enough information to reproduce this issue. I'm marking this as needsinfo, please reopen if you can provide a test case or a description of how to reproduce this issue.

comment:2 Changed 4 years ago by umbrae@…

For the record for anyone else who stumbles upon this ticket - it's a duplicate of the issue found here: https://code.djangoproject.com/ticket/6623

Note: See TracTickets for help on using tickets.
Back to Top