Opened 3 years ago

Closed 3 years ago

#16930 closed Cleanup/optimization (duplicate)

Class names ending with 'y' should be 'ie' in plural

Reported by: anonymous Owned by: nobody
Component: contrib.admin Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Assuming you have a Class 'History' that is available in the Django Admin Interface, Django should display it as 'Histories' - currently, it shows 'Historys'.

Change History (1)

comment:1 Changed 3 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of a very old ticket, #569, that was closed wontfix. I don't think anything has changed in the interim to reverse that decision. Specify verbose_name_plural to get the correct plural shown in the admin.

Note: See TracTickets for help on using tickets.
Back to Top