Opened 4 years ago

Closed 14 months ago

#16877 closed Bug (fixed)

documentation code blocks cropped on mobile browsers

Reported by: dardub@… Owned by: nobody
Component: *.djangoproject.com Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I tried to follow along with the tutorials using my nook color browser. The code blocks are cut off at the end of the line. They do not have a horizontal scroll like on my computer's browser. I'm guessing this also affects some of the other android tablets. I was using the default nook browser.

Change History (5)

comment:1 Changed 4 years ago by ptone

  • Component changed from Documentation to Djangoproject.com Web site
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • UI/UX unset

This has been a long standing problem for mobile browsers, and I assumed it was already in trac - but can not find anything that would justify this being marked as duplicate.

For a rough, old, and inadequate solution - see an old blog post of mine: http://ptone.com/dablog/2009/02/reading-djangos-docs-on-iphone/

Since this would probably need to be solved in the specific serving context of djangoproject.com - I'm changing the component.

comment:2 Changed 4 years ago by ptone

  • Summary changed from documentation code blocks cropped on nook color to documentation code blocks cropped on mobile browsers

comment:3 Changed 3 years ago by aaugustin

I confirm this problem happens on Android (but not iOS).

comment:4 Changed 18 months ago by adamduren

Is this still an issue? I can see on my Android device that the code blocks may run long but I have the option to scroll horizontally. Android 4.3 Galaxy S3

comment:5 Changed 14 months ago by mardini

  • Resolution set to fixed
  • Status changed from new to closed

I tried to reproduce on several mobile devices/browsers, but it looks like the issue is fixed now, maybe because of how modern mobile browsers matured.

Note: See TracTickets for help on using tickets.
Back to Top