Opened 4 years ago

Closed 2 years ago

#16840 closed Bug (duplicate)

Bogus QuerySet.distinct(...) and QuerySet.select_related(...) arguments do not result in errors

Reported by: lamby Owned by: nobody
Component: Database layer (models, ORM) Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


User.objects.distinct('How come you can put anything here?')
User.objects.select_related('Seems like asking for trouble, frankly.')

Change History (3)

comment:1 Changed 4 years ago by carljm

  • Component changed from Uncategorized to Database layer (models, ORM)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • Type changed from Uncategorized to Bug

comment:2 Changed 4 years ago by lamby

The .distinct() case has been "accidentally" fixed by the support of "DISTINCT ON" queries.

The select_related() case is still problematic.

comment:3 Changed 2 years ago by bmispelon

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #10414.

Note: See TracTickets for help on using tickets.
Back to Top