Code

Opened 3 years ago

Closed 3 years ago

#16691 closed Bug (duplicate)

Slicing none() incorrectly returns a list (expected EmptyQuerySet)

Reported by: raymond.penners@… Owned by: nobody
Component: Database layer (models, ORM) Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I would expect the latter statement to return an (empty) QuerySet:

>>> type(User.objects.none())
<class 'django.db.models.query.EmptyQuerySet'>
>>> type(User.objects.all()[0:1])
<class 'django.db.models.query.QuerySet'>
>>> type(User.objects.none()[0:1])
<type 'list'>

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #10139

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.