Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16623 closed Bug (wontfix)

APPEND_SLASH changes request method

Reported by: h.a.clifford@… Owned by: nobody
Component: Core (Other) Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Discovered this while working on some backbone/piston CRUD

if my url is foo/
and I send a DELETE to foo, what actually happens is a GET on foo/ which when using CRUD is problem.

Obviously this is my fault for not correctly matching my urls, but discovering the root cause of why your DELETE is a GET is a surprising amount of effort!

Thanks

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by h.a.clifford@…

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

comment:2 Changed 3 years ago by PaulM

Leaving this closed, since the ticket opener closed it. For future searchers, the problem here is that the 'foo' url correction to 'foo/' uses a 301 redirect, which sets the Location header. Unfortunately, most user agents simply fall back to GETing at the new location, rather than asking the user if they wish to repeat the request. A 307 might fix the problem in some user agents, but it would confuse others.

http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.