Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1661 closed defect (fixed)

Forward declaration of OneToOneField requires 'to_field' to avoid import failure

Reported by: russellm Owned by: russellm
Component: Database layer (models, ORM) Version: magic-removal
Severity: normal Keywords:
Cc: lists@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by russellm)

njharman (lists@…) reports:

class Foo(models.Model):
   myfield = models.OneToOneField('SomeModel', to_field='id')

Works.

class Foo(models.Model):
   myfield = models.OneToOneField('SomeModel')

Fails because whatever "turns" 'SomeModel' from string into class object
hasn't happened when code in
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/django/db/models/fields/related.py
on line 510 tries to determine default to_field.


Model is ok during syncdb; failure occurs during import.

Change History (2)

comment:1 Changed 9 years ago by russellm

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

(In #3197) Fixed #1661 -- Added logic for string-form model references in the 'to' argument of OneToOneFields?. Includes regression test.

comment:2 Changed 9 years ago by adrian

  • milestone Version 0.92 deleted

Milestone Version 0.92 deleted

Note: See TracTickets for help on using tickets.
Back to Top