Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16525 closed Bug (wontfix)

Bug in get_language_from_request on python 2.4 and Ukrainian language

Reported by: AndrewG Owned by: nobody
Component: Internationalization Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Django 1.3, CentOS 5 (python 2.4).

HTTP_ACCEPT_LANGUAGE = 'uk,ru;q=0.8,en-us;q=0.5,en;q=0.3'

But get_language_from_request return ru.

normalized = locale.locale_alias.get(to_locale(accept_lang, True))

Not work, because:
locale_alias haven't "uk", in python 2.4. Its hard-coded.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

I'm sorry, but I'm going to close this bug as "wontfix": Django 1.4 won't support Python 2.4, and the problem isn't serious enough to be fixed in the maintenance branche (see the backport policy).

comment:2 Changed 3 years ago by russellm

This probably warrants some clarification: If someone were to present a ready-to-use patch, with test case, that didn't require a major performance overhead in order to support Python 2.4, then we would probably fix this. However, in the absence of a patch, we're closing the issue as an edge case we're willing to live with.

If you want to provide a patch, feel free to reopen this ticket.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.