Code

Opened 3 years ago

Closed 3 years ago

#16441 closed New feature (invalid)

Tutorial step1: Enable the project

Reported by: cesare.montresor@… Owned by: nobody
Component: Documentation Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

It's about django-nonrel for appengine, I don't know if this applies to all the cases.

I got trouble in following this documentation because for me was missing a step, that I have fixed it by guessing.
For my experience, would be nice to add at the end of the paragraph Creating a project the instructions to alter the main urls.py to route the requests into the project "mysite"

...
Make sure that your <project>/urls.py contains a row that look like this:

 (r'^mysite/', include('mysite.urls')),

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

I'm not sure why you think this is needed, but it isn't. Tutorial 3 covers the definition of URL patterns; Tutorial 1 doesn't require any modifications to the URL patterns in order to work, and adding a pattern for 'mysite.urls' when your project is called 'mysite' is a recipe for disaster later on (mysite.urls should be your top level URL patterns, so you shouldn't need to include it *anywhere*).

comment:2 Changed 3 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

First of all, it's my first experience on Django, so my opinion it's all but authoritative :)

Actually I got stuck at the page 2, Activate the admin site at the end of that paragraph I couldn't get the admin site working I got a 404.
So I thought I got to configure something else, like the url to the project...

comment:3 Changed 3 years ago by russellm

  • Resolution set to invalid
  • Status changed from reopened to closed

Firstly, I'm one of the core developers of Django, so I can assure that my opinion is about as authoritative as you're going to get.

Secondly, I can't emphasis strongly enough -- the sample URL configuration line you provide *is not required*, and *will cause problems* if you have a normal Django installation. Adding the line you propose to Django's tutorial would be categorically incorrect.

I don't know what's going on with your particular setup -- but the fact that you've mentioned both AppEngine and django-nonrel suggests that the problem lies in some eccentricity associated with that platform. The tutorial provides the correct instructions for someone using Django "as intended". i.e., as a standalone server, against a normal SQL database. I can't speak to how Django should be used against AppEngine, and Django's documentation isn't really the right place to discuss AppEngine.

I suggest that you take this up on the mailing list or #django in IRC -- or possibly on a mailing list appropriate to AppEngine or django-nonrel.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.