Opened 9 years ago

Closed 9 years ago

#1629 closed defect (duplicate)

Entering date before 1900 breaks admin section

Reported by: django.trac@… Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The administration section allows dates before the year 1900 to be entered. However, this breaks the admin section.

I'm getting lots of Python tracebacks when browsing the admin section. Most important is this message: ValueError at /admin/polls/polls/3/year=1212 is before 1900; the datetime strftime() methods require year >= 1900

The admin pane should probably not allow dates before 1900 to be entered.

(Note: this is my first day with Django. Maybe this is not a bug at all; I may be overlooking something. If this is the case, apologies.)

Change History (1)

comment:1 Changed 9 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Entering date before 1900 breaks admin section to Entering date before 1900 breaks admin section

dup of #1070

Note: See TracTickets for help on using tickets.
Back to Top