Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16255 closed Cleanup/optimization (fixed)

Drop support for Posgres versions < 8.2 for Django 1.4

Reported by: Ramiro Morales Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

A year ago a discussion was started in the django-dev mailing list about making official the minimum PostgreSQL version to be supported by Django for the in-development 1.3 release.

No clear consensus was reached and so, no action items resulted from it.

This ticket proposes simply dropping support for anything older that 8.2. Both 8.0 and 8.1 reached EOL in Nov 2010. See http://wiki.postgresql.org/wiki/PostgreSQL_Release_Support_Policy

The resulting code cleaanup could help in fixing #10509, #11285, #12180

Attachments (2)

16255.1.diff (5.9 KB) - added by Ramiro Morales 5 years ago.
Patch for this issue, included docs changes
16255.2.diff (6.1 KB) - added by Ramiro Morales 5 years ago.
One more if condition missed in previous patch

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by Ramiro Morales

Summary: Drop support for Posgres versions < 8.0 for Django 8.4Drop support for Posgres versions < 8.0 for Django 1.4

comment:2 in reply to:  description Changed 5 years ago by Ramiro Morales

Replying to ramiro:

No clear consensus was reached and so, no action items resulted from it.

For completeness, this is wrong, there was one change to the databases notes document explicitly marking 8.0 as the minimum but suggesting going for 8.2: https://code.djangoproject.com/changeset/13363/django/trunk/docs/ref/databases.txt

Changed 5 years ago by Ramiro Morales

Attachment: 16255.1.diff added

Patch for this issue, included docs changes

comment:3 Changed 5 years ago by Ramiro Morales

Has patch: set

Changed 5 years ago by Ramiro Morales

Attachment: 16255.2.diff added

One more if condition missed in previous patch

comment:4 Changed 5 years ago by Ramiro Morales

Summary: Drop support for Posgres versions < 8.0 for Django 1.4Drop support for Posgres versions < 8.2 for Django 1.4

comment:5 Changed 5 years ago by Aymeric Augustin

Triage Stage: UnreviewedAccepted

This looks reasonable.

If people are unable to upgrade to PostgreSQL 8.2 or later, they will also be unable to upgrade to Django 1.4; we can live with that.

comment:6 Changed 5 years ago by Ramiro Morales

Resolution: fixed
Status: newclosed

In [16423]:

Fixed #16255 -- Raised minimum PostgreSQL version supported to 8.2.

comment:7 Changed 5 years ago by Jacob

milestone: 1.4

Milestone 1.4 deleted

Note: See TracTickets for help on using tickets.
Back to Top