Code

Opened 3 years ago

Closed 3 years ago

#16215 closed New feature (duplicate)

FormSet and ModelFormSet Class-based views

Reported by: AndrewIngram Owned by: nobody
Component: Generic views Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

With all the nice new class-based views, it seems like a bit of an oversight that there aren't any for handling formsets. I've actually developed some myself that work very well and I'm interested in contributing them to Django. They still need a bit of work, they borrow a lot from the form views and may not be as elegant as possible, there's also a few missing features like support for inline formsets. However, they have very good test coverage and I think with a bit more work could be ready for inclusion.

Is there any interest in this?

Current code is at: https://github.com/AndrewIngram/django-extra-views/blob/master/extra_views/formsets.py

I'll finish the cleanup and submit a patch if the ticket is accepted.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by rasca

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #16256

We have a working patch there with multiple formsets and modelformsets support, and multiple inline formsets also.

I'll try to review this code in terms of API, and comment or update the patch in #16256.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.