Opened 4 years ago

Closed 3 years ago

#16142 closed Bug (needsinfo)

Coming admin FilterSpec implementation limits querying functionality

Reported by: subsume@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by jezdez)

<jezdez> subsume: please elaborate
<jezdez> or point me to the section where the use case is described if this has been discussed before
<subsume> jezdez here's a test case I whipped up at the time
<jezdez> subsume: why don't you use fm.Company.objects.filter(locations__zip_code="90210", locations__open_days="WEEKEND")?
<subsume> jezdez I certainly don't mind but that's not the QS that will be generated by the admin filter implementation in place
<jezdez> subsume: not you lost me, what exactly do you want?
<jezdez> *now
<subsume> I wanted a hook to override the broken behavior so I can achieve what you typed. Right now the filters will just loop over and over tacking on a new .filter() each time
<subsume> Because in your case it was part of the same join. In the current implementation its not.
<jezdez> subsume: okay, I must have missed that notion from the ticket, please open a ticket and state this exact reason. and no, this shouldn't be fixed with yet another hook, but by making the default filtering more effective in the first
<jezdez> place
<Finity> anyone know how a FileField handle's a blank file
<Finity> apparently it gets set to None, but if I change the file, it apparently doesn't abide by my upload_to rules >_>
<jezdez> subsume: feel free to refer to our conversation here, so it's not lost

The problem is illustrated above and is a continuation of the discussion at #5833.

Change History (4)

comment:1 Changed 4 years ago by jezdez

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 4 years ago by jezdez

  • Description modified (diff)

comment:3 Changed 4 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:4 Changed 3 years ago by aaugustin

  • Resolution set to needsinfo
  • Status changed from new to closed

I cannot understand what this ticket is about :/

Note: See TracTickets for help on using tickets.
Back to Top