Code

Opened 3 years ago

Closed 3 years ago

#16125 closed Cleanup/optimization (duplicate)

document BoundField's id_for_label attribute

Reported by: Keryn Knight <keryn@…> Owned by: nobody
Component: Documentation Version: 1.3
Severity: Normal Keywords: boundfield forms
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX:

Description

As there is no separate documentation on BoundField -- its just rolled into the page on forms -- it would be good to have additional fields even passingly documented under the section on looping over the form's fields. Specifically, it may be necessary on occassion to target one field with more than one label, which requires knowledge of BoundField.id_for_label or rooting through the source code.

I'd be tempted to also document css_classes and auto_id, although I suppose auto_id could be considered private?https://code.djangoproject.com/browser/django/trunk/django/forms/forms.py

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed
  • Triage Stage changed from Unreviewed to Design decision needed

This is a duplicate of #12856.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.