Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16062 closed Bug (duplicate)

Broken Pipe in FireFox

Reported by: rowend07@… Owned by: rowend
Component: HTTP handling Version: 1.3
Severity: Normal Keywords: broke pipe in firefox
Cc: rowend07@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX:

Description

Hi my name is Ramiro Tinoco Duarte also you can callme by my nickname.
I am a new porgrammer in django.
And my English is not good.
But I try to explain the error.

Enviroment
SO - Ubuntu 10.10
web-browser firefox 3.6.17
django version 1.3

error

Traceback (most recent call last):

File "/usr/local/lib/python2.6/dist-packages/django/core/servers/basehttp.py", line 284, in run

self.finish_response()

File "/usr/local/lib/python2.6/dist-packages/django/core/servers/basehttp.py", line 324, in finish_response

self.write(data)

File "/usr/local/lib/python2.6/dist-packages/django/core/servers/basehttp.py", line 403, in write

self.send_headers()

File "/usr/local/lib/python2.6/dist-packages/django/core/servers/basehttp.py", line 467, in send_headers

self.send_preamble()

File "/usr/local/lib/python2.6/dist-packages/django/core/servers/basehttp.py", line 385, in send_preamble

'Date: %s\r\n' % http_date()

File "/usr/lib/python2.6/socket.py", line 318, in write

self.flush()

File "/usr/lib/python2.6/socket.py", line 297, in flush

self._sock.sendall(buffer(data, write_offset, buffer_size))

error: [Errno 32] Broken pipe


Exception happened during processing of request from ('127.0.0.1', 35205)
Traceback (most recent call last):

File "/usr/lib/python2.6/SocketServer.py", line 283, in _handle_request_noblock

self.process_request(request, client_address)

File "/usr/lib/python2.6/SocketServer.py", line 309, in process_request

self.finish_request(request, client_address)

File "/usr/lib/python2.6/SocketServer.py", line 322, in finish_request

self.RequestHandlerClass(request, client_address, self)

File "/usr/local/lib/python2.6/dist-packages/django/core/servers/basehttp.py", line 570, in init

BaseHTTPRequestHandler.init(self, *args, kwargs)

File "/usr/lib/python2.6/SocketServer.py", line 618, in init

self.finish()

File "/usr/lib/python2.6/SocketServer.py", line 661, in finish

self.wfile.flush()

File "/usr/lib/python2.6/socket.py", line 297, in flush

self._sock.sendall(buffer(data, write_offset, buffer_size))

error: [Errno 32] Broken pipe


why causes this error in firefox
put the next html code in a template

<a href = 'someUrlMaybeOneRealOrOneDoesNotExitOrThisWord' ><button>some text<button></a>

and when you click the button-link the error occurs
a great broken pipe line

I apologize for my bads english skills

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #16061

comment:2 Changed 3 years ago by jacob

Milestone 2.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.