Opened 4 years ago

Closed 4 years ago

#16019 closed Bug (duplicate)

increase max_length on django.contrib.auth User model

Reported by: wildfire Owned by: nobody
Component: contrib.auth Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX:



Whilst not everyone does, some people utilise the username field in the User model to store the email address.

Which allows people to login using that.

However the field length of the username field (30) is significantly shorter than email (75)

It would be nice if the username length was bumped to be the same value; nice as in making the lives of developers somewhat easier.

Change History (1)

comment:1 Changed 4 years ago by vrehak

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Quting russellm from #15022:

Duplicate of #12900, #11579, #11365, and many others.

The advantage is backwards compatibility. Every single Django site in existence that uses contrib.auth has a synchronized database with an email field of length 75 characters. Yes, this length is too short for some uses. But we don't currently have a way to ship migrations and ensure that they are applied.

The likely fix for this is #3011 -- making the user module user-definable. It isn't as simple as "just increase the max_length".

Note: See TracTickets for help on using tickets.
Back to Top