Opened 5 years ago

Closed 5 years ago

#15980 closed Bug (fixed)

Unknown encoding "utf8" in tests/regressiontests/views/__init__.py

Reported by: davidbarnett2@… Owned by: nobody
Component: Uncategorized Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX:

Description

From http://stackoverflow.com/questions/4370035/python-makemessages-errors-unknown-encoding-utf8:

I need to recompile the language pack for the OSQA system, but get this message:

Error: errors happened while running xgettext on __init__.py
xgettext: ./Django-1.2.3/tests/regressiontests/views/__init__.py:1: Unknown encoding "utf8". Proceeding with ASCII instead.
xgettext: Non-ASCII string at ./Django-1.2.3/tests/regressiontests/views/__init__.py:7.
          Please specify the source encoding through --from-code or through a comment
          as specified in http://www.python.org/peps/pep-0263.html.

I think this is purely a matter of changing "utf8" to "utf-8" in that one file. I grepped and didn't find "coding: utf8" in any other files.

Change History (2)

comment:1 Changed 5 years ago by Julien Phalip

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedReady for checkin

comment:2 Changed 5 years ago by Luke Plant

Resolution: fixed
Status: newclosed

In [16170]:

Fixed #15980 - Unknown encoding "utf8" in tests/regressiontests/views/init.py

Thanks to davidbarnett2 for the report

Note: See TracTickets for help on using tickets.
Back to Top