Code

Opened 3 years ago

Closed 3 years ago

#15944 closed Cleanup/optimization (duplicate)

Cross-reference contrib.auth.models.check_password and contrib.auth.models.User.check_password

Reported by: airstrike Owned by: nobody
Component: Documentation Version: 1.3
Severity: Normal Keywords: docs auth User check_password
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:

Description

http://docs.djangoproject.com/en/1.3/topics/auth/#django.contrib.auth.models.check_password
http://docs.djangoproject.com/en/1.3/topics/auth.html#django.contrib.auth.models.User.check_password

I believe these two sections should be cross-referenced, so I'm attaching a patch with my proposal changes for this section of the docs. I was also getting a warning with sphinx when trying to build auth.txt from trunk that read

docs/topics/auth.txt:3: (SEVERE/4) Duplicate ID: "module-django.contrib.auth.views".

I'm attaching a second patch which aims to solve that issue as well. I'm not sure if the solution is correct, but it "worksforme" on a new sphinx build attempt.

This is my first patch ever, so proceed with caution!

Attachments (2)

topics_auth_crossreferencecheckpassword.diff (1.0 KB) - added by airstrike 3 years ago.
topics_auth_removeduplicateviews.diff (400 bytes) - added by airstrike 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by airstrike

Changed 3 years ago by airstrike

comment:1 Changed 3 years ago by airstrike

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I also apologize in advance if i happened to be too verbose in my patch.

comment:2 Changed 3 years ago by jezdez

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15942

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.