Code

Opened 3 years ago

Closed 3 years ago

#15905 closed Bug (invalid)

Forms keyword arguments..

Reported by: mpamukcu@… Owned by: nobody
Component: Forms Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:

Description

when i try to validate my form its is_valid function returns False when i code like this:
form = ProductMetaForm(post)

if form.is_valid():

return True

else:

return False

but, if i equiliaze post to data keyword arg , then it returns True:
in example:

form = ProductMetaForm(data = post)

if form.is_valid():

return True

else:

return False

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by lukeplant

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Looking at the implementation of django.forms.Form, there is really no way that that can happen, since data is the first positional argument. There must be something more that is not included in the information here e.g. your implementation of ProductMetaForm.

In fact, this sounds more like a support request than a bug (which are not appropriate for Django's tracker), so, since there is not nearly enough information to suggest a bug in Django here, I'm going to close as INVALID. Please re-open if you can show a genuine bug in Django itself with enough information to reproduce it.

Also, please use Trac preview and WikiFormatting to ensure code comes out correctly.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.