Opened 4 years ago

Closed 4 years ago

#15868 closed Bug (duplicate)

Auth Group Admin Bug

Reported by: uriel.bertoche@… Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:


When your app has too many permissions, it takes an eternity to execute a request to auth_group admin page.
It makes as many SQL queries as permissions existent.

My app has for now, 350 permissions, after having that problem I installed django_debug_tools to see what was happening. When I load group admin page, Django makes 350 queries in SQL and uses 5500ms in processor time.

Though, when I load user admin page, which shows permissions the same way group admin does, it loads really fast.

Group admin is loading SO slow, it even fails to load on a server like Apache or nGinx, it only loads on Django test server.

Attachments (1)

Screenshot-Add group | Django site admin - Chromium.png (120.9 KB) - added by uriel.bertoche@… 4 years ago.
django auth group admin issue

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by uriel.bertoche@…

django auth group admin issue

comment:1 Changed 4 years ago by yishaibeeri

  • Easy pickings unset
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15206

Note: See TracTickets for help on using tickets.
Back to Top