Code

Opened 3 years ago

Closed 3 years ago

#15864 closed Uncategorized (duplicate)

django generates strange error

Reported by: satarsa Owned by: nobody
Component: Uncategorized Version: 1.3-beta
Severity: Normal Keywords:
Cc: dyadkin@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm not sure it is a bug or not. If I add this string:

++++++++++++++++++++++++++++++++++++++++++++Result:+%ED%E5+%ED%E0%F8%EB%EE%F1%FC+%F4%EE%F0%EC%FB+%E4%EB%FF+%EE%F2%EF%F0%E0%E2%EA%E8;

to any django's url (like http://example.com/djangoapp/suburl+++...), it generates error of this kind:

[Wed Apr 20 16:31:06 2011] [error] [client 195.19.214.230] mod_wsgi (pid=23117): Exception occurred processing WSGI script '/var/www/localhost/htdocs/fks2011/django.wsgi'.
[Wed Apr 20 16:31:06 2011] [error] [client 195.19.214.230] Traceback (most recent call last):
[Wed Apr 20 16:31:06 2011] [error] [client 195.19.214.230]   File "/usr/lib64/python2.7/site-packages/django/core/handlers/wsgi.py", line 264, in __call__
[Wed Apr 20 16:31:06 2011] [error] [client 195.19.214.230]     logger.warning('Bad Request (UnicodeDecodeError): %s' % request.path,
[Wed Apr 20 16:31:06 2011] [error] [client 195.19.214.230] UnboundLocalError: local variable 'request' referenced before assignment

instead of generating 404 (as it is for half of this strange string).

This works for all my django apps v1.3

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by satarsa

  • Cc dyadkin@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 3 years ago by vung

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15672

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.