Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15857 closed Uncategorized (duplicate)

contrib.contenttypes depends on contrib.auth

Reported by: lsaffre Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Currently it is not possible to successfully run test on a site that has contenttypes but not django.contrib.auth installed. That's an a limiting dependency.
I suggest to add a line in the test suite of django.contrib.contenttypes:

...
from django.contrib.auth.models import User
if not User._meta.installed: return            ## THE NEW LINE
user_ct = ContentType.objects.get_for_model(User)
...

Attachments (1)

contenttypes_auth.diff (505 bytes) - added by lsaffre 3 years ago.
Patch against rev. 15796

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by lsaffre

Patch against rev. 15796

comment:1 Changed 3 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #14543.

comment:2 Changed 3 years ago by julien

oops, that was me...

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.