Opened 4 years ago

Closed 4 years ago

#15824 closed Bug (wontfix)

Modpython should catch EPIPE (produces 500 Internal Server Error)

Reported by: gkuenning Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When a browser client is receiving a page and decides to go away for
whatever reason, Apache throws an internal server error that
eventually produces an e-mail message to the admin. It took me quite
a while to figure out why I was getting these random error messages.

The problem is in modpython at around line 220:

try:

for chunk in response:

req.write(chunk)

finally:

response.close()

If the client closes the connection during this loop, the write will
throw an exception. It is my belief that this code should include an
except clause to catch and discard EPIPE, since it's not a server
error when clients go away.

Change History (1)

comment:1 Changed 4 years ago by carljm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

Closing this wontfix, as mod_python support is deprecated and will be removed in Django 1.5.

Note: See TracTickets for help on using tickets.
Back to Top