Opened 4 years ago

Closed 4 years ago

#15803 closed New feature (duplicate)

A slug on form fields like 'select' 'input' or 'checkbox'

Reported by: whalesalad Owned by: nobody
Component: Forms Version:
Severity: Normal Keywords: forms fields widgets slugs
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I'd love to have a slug on form fields so that inside of templates I can do things like, "if this is a checkbox, use this markup, otherwise use this other markup". Something like "{% ifequal field.type 'checkbox' %}" would be dandy. This might already exist in an alternate form, but I can't seem to figure it out.

This is just a feature request... I hope that submitting something like this on Trac isn't out of line.

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to mark this as a duplicate of #15667. That ticket is proposing a move to template-based widget rendering, which should be a superset of what you're describing here.

Note: See TracTickets for help on using tickets.
Back to Top