Code

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#15649 closed Bug (wontfix)

Doc buliding fails with: DjangoHTMLTranslator instance has no attribute '_table_row_index'

Reported by: bmihelac Owned by: nobody
Component: Documentation Version: 1.3
Severity: Normal Keywords:
Cc: lists@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by ramiro)

When trying to make documentation with make html, following exception is raised:

Exception occurred:
  File "/Users/bmihelac/dev/django/src/sphinx/sphinx/writers/html.py", line 523, in visit_row
    self._table_row_index += 1
AttributeError: DjangoHTMLTranslator instance has no attribute '_table_row_index'
  • Sphinx version: 1.1pre/ce4bb37a1409
  • Python version: 2.6.6
  • Docutils version: 0.7 release
  • Jinja2 version: 2.5

Attachments (0)

Change History (10)

comment:1 Changed 3 years ago by gabrielhurley

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Can you test whether this error occurs under Sphinx 1.0.7 (the current stable release)? I can't reproduce this bug, and I suspect it has more to do with the pre-release version of Sphinx you've got there.

comment:2 Changed 3 years ago by bmihelac

  • Resolution set to invalid
  • Status changed from new to closed

Yes, with Sphinx 1.0.7 it works. i'll mark it as invalid.

comment:3 Changed 3 years ago by gavenkoa@…

  • Easy pickings unset
  • Resolution invalid deleted
  • Severity set to Normal
  • Status changed from closed to reopened
  • Type set to Uncategorized
  • UI/UX unset
  $ make html
sphinx-build -b djangohtml -d _build/doctrees   . _build/html
Running Sphinx v1.0.8
loading pickled environment... not yet created
building [djangohtml]: targets for 205 source files that are out of date
updating environment: 205 added, 0 changed, 0 removed
reading sources... [100%] topics/testing
looking for now-outdated files... none found
pickling environment... done
checking consistency... done
preparing documents... done
writing output... [  7%] howto/custom-management-commands
Exception occurred:
  File "/usr/lib/python2.6/site-packages/Sphinx-1.0.8-py2.6.egg/sphinx/writers/html.py", line 120, in visit_desc_parameter
    self.body.append(self.param_separator)
AttributeError: DjangoHTMLTranslator instance has no attribute 'param_separator'
Last edited 3 years ago by ramiro (previous) (diff)

comment:4 Changed 3 years ago by andreas_pelme

  • Resolution set to invalid
  • Status changed from reopened to closed

This is an old bug for another version of Sphinx that you are reporting, is this the same problem? Can you provide more specific instructions and versions for how to reproduce this?

I can successfully build the html documentation from the latest django trunk with Python 2.6.6, docutils 0.8.1, Sphinx 1.0.8, Jinja2 2.6, Pygments==1.4 on Mac OS X 10.7/Lion.

Please open a new ticket with complete instructions for how to reproduce this, including platform, what versions of the libraries you are using.

comment:5 Changed 3 years ago by gavenkoa@…

I install from sources official Sphinx 1.0.8 to latest Cygwin distro and try build 'make html'.

Note than lately I found Sphinx 1.0.7 package under Cygwin. With this version docs build work like a charm.

comment:6 Changed 2 years ago by Thijs Triemstra <lists@…>

  • Cc lists@… added

Also fails with Sphinx 1.1 (current stable version).

comment:7 Changed 2 years ago by Thijs Triemstra <lists@…>

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from Uncategorized to Bug
  • Version changed from SVN to 1.3
thijs@ubuntu:~$ cd Downloads/Django-1.3.1/docs/
thijs@ubuntu:~/Downloads/Django-1.3.1/docs$ make html
sphinx-build -b djangohtml -d _build/doctrees   . _build/html
Making output directory...
Running Sphinx v1.1
loading pickled environment... not yet created
building [djangohtml]: targets for 205 source files that are out of date
updating environment: 205 added, 0 changed, 0 removed
reading sources... [100%] topics/testing                                                                                               
looking for now-outdated files... none found
pickling environment... done
checking consistency... done
preparing documents... done
writing output... [  5%] howto/apache-auth                                                                                             
Exception occurred:
  File "/usr/local/lib/python2.7/site-packages/Sphinx-1.1-py2.7.egg/sphinx/writers/html.py", line 522, in visit_row
    self._table_row_index += 1
AttributeError: DjangoHTMLTranslator instance has no attribute '_table_row_index'
The full traceback has been saved in /tmp/sphinx-err-vX7RVN.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at <http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!
make: *** [html] Error 1

That's with Python 2.7.1/Django 1.3.1/Ubuntu 11.04/Sphinx 1.1.

comment:8 Changed 2 years ago by ramiro

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from reopened to closed

Please don't report different errors is the same ticket.

There are two issues reported in this ticket:

Fist, the

Exception occurred:
  File ".../sphinx/writers/html.py", line 522, in visit_row
    self._table_row_index += 1

error. It's triggered by a change between Sphinx 1.0.x and 1.1. We fixed (or rather worked around) it for our trunk docs in r16223 but we didn't backport it to the 1.3.x branch and now it's too late for us to change our custom HTML builder code in the 1.3.1 release tarball.

Second, the

Exception occurred:
  File ".../sphinx/writers/html.py", line 120, in visit_desc_parameter
    self.body.append(self.param_separator)

error. This is a similar case: It also originates in a change introduced during the Sphinx 1.1 development cycle and in 1.0.8. We also had to workaround it (r16231) and didn't backport it to 1.3.x either. AFAICT is is a badly implemented change will try to open a ticket in Sphinx issue tracker so it is fixed for 1.1.x.

In short: If you want to build the 1.3 or 1.3.1 Django docs use Sphinx 1.0.7 or older.

comment:9 Changed 2 years ago by aaugustin

#17177 was a duplicate.

comment:10 Changed 2 years ago by anonymous

You might want to consider to port the fix to 1.3.x since this occurs on CentOS/RHEL 6.2.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.