Opened 4 years ago

Closed 4 years ago

#15599 closed (duplicate)

If a user doesn't have delete permission on a model, the delete action shouldn't ve shown in the admin interface

Reported by: jjconti Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Keywords: delete permission action
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the admin interface, when listing all the models of a kind, you get the "delete all selected models" action. When you execute it, you get an ugly un-css H1 message saying: "Permission denied". I think the action shouldn't be present.

Change History (1)

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10609.

Note: See TracTickets for help on using tickets.
Back to Top