Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15515 closed (duplicate)

Django should support customizable project/app templates

Reported by: Joshua "jag" Ginsberg <jag@…> Owned by: nobody
Component: Core (Other) Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The django management startproject and startapp commands use the templates in /django/conf/(project|app)_template without any option to use anything else. That's silly. The attached patch allows the user to specify the path to an alternate template, processed in the same manner.

Attachments (1)

django-15515.diff (4.0 KB) - added by Joshua "jag" Ginsberg <jag@…> 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Joshua "jag" Ginsberg <jag@…>

comment:1 Changed 3 years ago by Joshua "jag" Ginsberg <jag@…>

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 3 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3999.

comment:3 Changed 3 years ago by russellm

#15095 is also worth mentioning as a prior ticket -- especially since it isn't closed.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.