Code

Opened 3 years ago

Closed 3 years ago

#15498 closed (worksforme)

selectfilter broken when there are multiple in a admin

Reported by: p.vanderlinden@… Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Keywords: selectfilter
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When there are multiple selectfilters (filter_horizontal/filter_vertical), on an admin page, the data isn't transmitted when you submit the form. All data in the Many2ManyField is deleted.

This bug depends on the browser:
Works correct in Firefox, works incorrect in Internet Explorer 8 & Opera 11.01.

As attachment I've added a quickly written jQuery plugin.

Attachments (1)

jquery.multiselectfilter.js (6.1 KB) - added by p.vanderlinden@… 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by p.vanderlinden@…

comment:1 Changed 3 years ago by russellm

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

Two problems here:

  1. I can't reproduce the problem you describe. I just created a test project with two filter_horizontals, and it worked fine for me.
  2. Even if I *could* reproduce the problem, the fix isn't going to be a random block of standalone javascript -- it's going to be a patch against the existing javascript implementation of filter_horizontal/vertical.

However, the second point is moot given that you haven't provided enough detail to reproduce the problem you are seeing.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.