Code

Opened 3 years ago

Closed 3 years ago

#15384 closed (duplicate)

TestAppDirectoriesFinder fails in Windows

Reported by: anonymous Owned by: nobody
Component: Uncategorized Version: 1.3-beta
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I ran the Django 1.3 beta 1 tests using the included sqlite backend in a Windows 7 machine. The TestAppDirectoriesFinder failed because of the Windows slashes:

======================================================================
FAIL: test_find_all (regressiontests.staticfiles_tests.tests.TestAppDirectoriesFinder)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\Users\cesar\Documents\apps\Django-1.3-beta-1\tests\regressiontests\staticfiles_tests\tests.py", line 323, in test_find_all
    self.assertEquals(self.finder.find(src, all=True), dst)
AssertionError: Lists differ: [u'c:\\users\\cesar\\documents... != ['C:\\Users\\cesar\\Documents\...

First differing element 0:
c:\users\cesar\documents\apps\django-1.3-beta-1\tests\regressiontests\staticfiles_tests\apps\test\static\test\file1.txt
C:\Users\cesar\Documents\apps\Django-1.3-beta-1\tests\regressiontests\staticfiles_tests\apps/test/static/test/file1.txt

- [u'c:\\users\\cesar\\documents\\apps\\django-1.3-beta-1\\tests\\regressiontests\\staticfiles_tests\\apps\\test\\static\\test\\file1.txt']
?  - ^   ^             ^                ^                                                                 ^^    ^^      ^^    ^^

+ ['C:\\Users\\cesar\\Documents\\apps\\Django-1.3-beta-1\\tests\\regressiontests\\staticfiles_tests\\apps/test/static/test/file1.txt']
?   ^   ^             ^                ^                                                                 ^    ^      ^    ^

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to close this as a duplicate of #14961; even if it isn't that problem, there have been many changes to the staticfiles tests since beta1, and some of those were specifically to address Windows problems.

Please reopen if you can reproduce this on a current trunk checkout.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.