Code

Opened 3 years ago

Closed 3 years ago

#15374 closed (invalid)

Polish dates being wrongly shortened.

Reported by: muaddib@… Owned by: nobody
Component: Internationalization Version: 1.3-beta
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In newer versions of django month names are being pretty shortened.
'January' is 'Jan.'
while 'June' stays 'June'.

Polish names are being also shortened, but char counting is still derived from english name length.
'Styczen' is 'Sty.' which is ok, but
'Luty' is 'Lut.' which should not be shortened.

Full table below

  1. Styczeń/January
  2. Luty/February
  3. Marzec/March
  4. Kwiecień/April
  5. Maj/May
  6. Czerwiec/June
  7. Lipiec/July
  8. Sierpień/August
  9. Wrzesień/September
  10. Październik/October
  11. Listopad/November
  12. Grudzień/December

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Translations are now being handled through Transifex. If you want to help correct the Polish translation, sign up with the Polish translation team and pitch in.

comment:2 follow-up: Changed 3 years ago by muaddib@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

The problem reported wasnt about translated strings, but more about the way django admin treats them.

The names are being shortened taking into account english length of the respective month name, not the translated one.
In english and polish both names are long (January = Styczeń) but the second month of the year has short name in Polish (only four characters) so it should not be shortened. But it is still shortened. I belive this happens due to english 'February' is long.
This also happens in the opposite direction. The fourth month is 'Kwiecień' and it is not shortened at all (probably because 'april' is a short name).

I checked other months and the pattern seems to be the case.

It can be caused by some misconfiguration. For that I am not sure. The problem popped up right after upgrading to 1.3-beta1 from older version (1.1 if i remember correctly).

comment:3 in reply to: ↑ 2 Changed 3 years ago by russellm

  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to muaddib@…:

The problem reported wasnt about translated strings, but more about the way django admin treats them.

The names are being shortened taking into account english length of the respective month name, not the translated one.

Erm... no, they're not. They're being shortened as part of the translation.

I'm not aware of anywhere that Django uses the length of the english word to shorten a translated word. The fact that the translations actually demonstrate the problem you're describing backs up that assertion.

Closing invalid, since as far as I can make out, this is definitely a translation problem. Please don't reopen unless you can point at a *specific* line of code where we're doing the wrong thing.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.