Opened 4 years ago

Closed 4 years ago

#15301 closed Bug (duplicate)

GenericInlineModelAdmin's get_formset() method does not have same arg signature/behavior as InlineModelAdmin

Reported by: anonymous Owned by: nobody
Component: contrib.contenttypes Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:

Description

This leads to difficulty when trying to override get_formset() in a subclass

Note that it takes kwargs and will update the defaults:
http://code.djangoproject.com/browser/django/trunk/django/contrib/admin/options.py#L1297

No kwargs/no update:
http://code.djangoproject.com/browser/django/trunk/django/contrib/contenttypes/generic.py#L402

Change History (4)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 4 years ago by gabrielhurley

  • Component changed from Contrib apps to contrib.contenttypes

comment:3 Changed 4 years ago by lrekucki

  • Severity set to Normal
  • Type set to Bug

comment:4 Changed 4 years ago by prestontimmons

  • Easy pickings unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #9588.

Note: See TracTickets for help on using tickets.
Back to Top