Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15274 closed (fixed)

UpdateView raises exception about overiding get_object

Reported by: sergeybe@… Owned by: nobody
Component: Generic views Version: 1.3-beta
Severity: Keywords: blocker
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I've defined the view class:

class OneAuthorUpdate(generic.UpdateView):

    def get_object(self):
        return Author.objects.get(pk=1)

But next exception raises:

ImproperlyConfigured: OneAuthorUpdate is missing a queryset. Define OneAuthorUpdate.model, OneAuthorUpdate.queryset, or override OneAuthorUpdate.get_object()

Attachments (1)

tests_for_get_object.patch (3.8 KB) - added by Sergey N. Belinsky <sergeybe@…> 3 years ago.
Tests for UpdateView and get_object method

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Sergey N. Belinsky <sergeybe@…>

Tests for UpdateView and get_object method

comment:1 Changed 3 years ago by russellm

  • Keywords blocker added
  • milestone set to 1.3
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Confirmed that the test case fails as described; need to dig in closer to see exactly why. Marking as a blocker for the moment, because at the very least, it's confusing.

comment:2 Changed 3 years ago by russellm

I've found the cause -- you've overridden get_object, but you haven't provided a form, so the call to get_form_class() is calling get_queryset() as a cheats way to find the model that can be used to automatically construct a ModelForm.

The simple workaround -- specify a form_class. I'm looking into what we can do as a permanent solution.

comment:3 Changed 3 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

In [15540]:

Fixed #15247 -- Ensured that if a SingleObject? view defines get_object but not get_queryset, the ModelFormMixin? doesn't fail. Thanks to Sergey N. Belinsky for the report and test case.

(Fat fingers attributed this to the wrong ticket)

comment:4 Changed 3 years ago by Sergey N. Belinsky <sergeybe@…>

It works now. Thank you!

comment:5 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.