Opened 9 years ago

Closed 8 years ago

#1527 closed enhancement (duplicate)

Makefile for HTML documentation

Reported by: Andy Dustman <farcepest@…> Owned by: jacob
Component: Documentation Version: master
Severity: trivial Keywords:
Cc: farcepest@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I wanted to be able to read the current SVN docs as HTML, so I put together a small Makefile (to go in the docs directory):

.SUFFIXES = .txt .html

%.html : %.txt
        rst2html.py $< $@

objects := $(patsubst %.txt,%.html,$(wildcard *.txt))
all: $(objects)

Assumes docutils and rst2html.py on your path, and GNU Make. Running make processes any .txt files to .html as needed. Will add as an attachment too to preserve tabs.

Attachments (1)

Makefile (129 bytes) - added by Andy Dustman <farcepest@…> 9 years ago.
Makefile for docs to convert ReST -> HTML

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Andy Dustman <farcepest@…>

Makefile for docs to convert ReST -> HTML

comment:1 Changed 9 years ago by adrian

Whoa, this is pretty cool. Thanks!

comment:2 Changed 9 years ago by Andy Dustman <farcepest@…>

  • Cc farcepest@… added
  • Version changed from magic-removal to SVN

Switched to SVN version since magic-removal is no longer relevant.

comment:3 Changed 9 years ago by Andy Dustman <farcepest@…>

buildhtml.py which comes with distutils will also do the same job, although it always rebuilds everything, unlike make which only rebuilds when the source is modified.

comment:4 Changed 9 years ago by Gary Wilson <gary.wilson@…>

  • milestone changed from Version 0.92 to Version 1.0

0.92 is long gone.

comment:5 Changed 9 years ago by anonymous

  • milestone Version 1.0 deleted

Milestone Version 1.0 deleted

comment:6 Changed 9 years ago by Simon G. <dev@…>

  • Triage Stage changed from Unreviewed to Accepted

Accepted on the basis of "whoa, this is cool!"

comment:7 Changed 8 years ago by Marc Fargas <telenieko@…>

  • Resolution set to duplicate
  • Status changed from new to closed

I think we can mark this as a duplicate of #528, #528 is about a PDF/HTML generator.
On the other hand this patch requires make and rst2html.py and the first one can be a bit tricky to have on some platforms (win..)

So, marking as duplicate of #528 ;)

Note: See TracTickets for help on using tickets.
Back to Top