Opened 5 years ago

Closed 4 years ago

#15242 closed Cleanup/optimization (duplicate)

Documentation titles should be weighted more heavily in seach.

Reported by: aimaz Owned by: nobody
Component: * Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


Documentation page titles are in general good and tend to contain things I'm searching for. As an example searching for "model field reference" will currently result in the page with that title appearing 12th. Whereas in a Google search it is the first result. Even putting the search term in quotes results in it coming 4th.

Change History (7)

comment:1 Changed 5 years ago by gabrielhurley

  • Component changed from Documentation to Django Web site
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Offhand I'm not sure how much control we have over the machinery of that search engine. While I agree that it could certainly do better, it may not be possible without replacing it with a completely different tool. I'm not an expert on the backend, though, so someone else will have to weigh in on this ticket as well.

It's not a docs issue, though, so I'm re-categorizing it.

comment:2 Changed 5 years ago by anonymous

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 5 years ago by russellm

We (potentially) have a lot more control now than we did previously -- we're now hosting our own search. This should be something we should be able to tweak. And if our current setup doesn't allow us to tweak it, then we should be looking for an alternative that will.

comment:4 Changed 5 years ago by lrekucki

  • Severity set to Normal
  • Type set to Cleanup/optimization

comment:5 Changed 4 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:6 Changed 4 years ago by aaugustin

  • Easy pickings unset

Change Easy pickings from NULL to False.

comment:7 Changed 4 years ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

I think we can keep only one ticket for improving search results relevancy, so I'll close this one as a dupe of #16011.

Note: See TracTickets for help on using tickets.
Back to Top