Opened 6 years ago

Closed 4 years ago

#15223 closed Bug (wontfix)

The comments app has 2 similar menu items in action

Reported by: sergeybe@… Owned by: Ashutosh Dwivedi
Component: contrib.comments Version: 1.3-beta
Severity: Normal Keywords: actions
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

There are two menu items:

  • Delete selected items
  • Remove selected items

I guess one from admin app and one from comments app.

Change History (13)

comment:1 Changed 6 years ago by anonymous

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedAccepted

I agree that this is confusing (I had to explain the difference between "Delete" and "Remove" to several clients before). "Remove" should perhaps be changed to "De-activate", or "Un-publish" or something along those lines.

comment:2 Changed 6 years ago by Julien Phalip

That was me :)

comment:3 Changed 6 years ago by Julien Phalip

milestone: 1.31.4

Not a bug though, so can't be done for 1.3.

comment:4 Changed 6 years ago by Simon Meers

No doubt originally named after the is_removed field on the Comment model, which seems perfectly reasonable until you see it beside the site-wide delete action. Should be a one-line patch. I think "Unpublish selected" sounds appropriate? (describes the effect better than "deactivate" or "hide").

comment:5 Changed 6 years ago by Ramiro Morales

milestone: 1.41.3

Julien, I disagree, this is a bug, even more a one-line translatable literal change. Can be worked on before 1.3 RC.

comment:6 Changed 6 years ago by Julien Phalip

@Ramiro Functionally things are consistent but I agree that this can be seen as a usability bug, and I'm absolutely in favour of fixing this ASAP. The patch may not be as trivial as modifying one string though. The term "removed" is also used in the comment's detail page and in the changelist's table and filters. If we change the term only in some places then things may potentially get even more confusing for the user.

comment:7 Changed 5 years ago by Łukasz Rekucki

Severity: Normal
Type: Bug

comment:8 Changed 5 years ago by Jacob

milestone: 1.3

Milestone 1.3 deleted

comment:11 Changed 5 years ago by Aymeric Augustin

UI/UX: unset

Change UI/UX from NULL to False.

comment:12 Changed 5 years ago by Aymeric Augustin

Easy pickings: unset

Change Easy pickings from NULL to False.

comment:13 Changed 4 years ago by Ashutosh Dwivedi

Owner: changed from nobody to Ashutosh Dwivedi
Status: newassigned

I've made a pull request for the patch here https://github.com/aashudwivedi/django/tree/ticket_15223

comment:14 Changed 4 years ago by Luke Plant

This is perhaps bikeshedding, but "unpublish/is unpublished" seems pretty clumsy language to me. "hide/is hidden" would be a lot better IMO.

comment:15 Changed 4 years ago by Jacob

Resolution: wontfix
Status: assignedclosed

django.contrib.comments has been deprecated and is no longer supported, so I'm closing this ticket. We're encouraging users to transition to a custom solution, or to a hosted solution like Disqus.

The code itself has moved to https://github.com/django/django-contrib-comments; if you want to keep using it, you could move this bug over there.

Note: See TracTickets for help on using tickets.
Back to Top