Opened 4 years ago

Closed 4 years ago

#15148 closed (duplicate)

International Domain Name (IDN) validation not working 100%

Reported by: halrobertson Owned by: nobody
Component: Core (Other) Version: 1.3-beta
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I am finding some domain names that are valid IDN's not validating with Django's URLValidator. I am using django 1.3.0 beta 1

I made a simple view to validate some IDN's, including those listed here: rooftopsolutions.nl/blog/internationalized-domain-names-are-you-ready

I have tried this with both python 2.5 and python 2.6 and have the same problems in both

Here's the view code I tried (attached)

Attachments (1)

views.py (1.1 KB) - added by halrobertson 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by halrobertson

comment:1 Changed 4 years ago by halrobertson

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 4 years ago by lrekucki

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12988.

Note: See TracTickets for help on using tickets.
Back to Top