Code

Opened 8 years ago

Closed 7 years ago

#1514 closed defect (duplicate)

No way to allow exceptions to raise out of Django

Reported by: ianb@… Owned by: adrian
Component: Core (Other) Version: master
Severity: normal Keywords:
Cc: ianb@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In trunk, django.core.handlers.base, exceptions are captured and displayed. However, in testing environments it is preferable that the exception not be handled and simply raised (or, for example, a rollback and then the exception is re-raised). There's no way to get it to do this now.

This also allows Django to use Paste's exception handlers. Paste in particular indicates this by putting environ['paste.throw_errors']=True into the WSGI environment, and does this both when an exception handler is already installed, and in testing environments.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Michael Radziej <mir@…>

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3452

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.