Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15133 closed (fixed)

:ref: directive in docs where :doc: directive should be used

Reported by: Aryeh Leib Taurog <vim@…> Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: vim@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using sphinx 1.0.7 I get the following warnings when building the docs:

/home/altaurog/djangodoc/trunk/docs/ref/signals.txt:15: WARNING: undefined label: topics-auth (if the link has no caption the label must precede a section header)
/home/altaurog/djangodoc/trunk/docs/releases/1.3-beta-1.txt:61: WARNING: undefined label: topics-auth (if the link has no caption the label must precede a section header)
/home/altaurog/djangodoc/trunk/docs/topics/auth.txt:660: WARNING: undefined label: topic-signals (if the link has no caption the label must precede a section header)

Changing the offending :ref: directives to :doc: directives seems to resolve this issue. i.e.

    The :doc:`authentication framework </topics/auth>` sends :ref:`signals when

Note that the reference in topics/auth.txt should be </topics/signals> not </topic/signals>

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by Aryeh Leib Taurog <vim@…>

  • Cc vim@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from :ref: directive in docs where :doc: directve should be used to :ref: directive in docs where :doc: directive should be used

comment:2 follow-up: Changed 3 years ago by russellm

  • Triage Stage changed from Unreviewed to Accepted

Confirmed; this appears to be a recent change, because Sphinx 1.0.7 reports the error, but Sphinx 1.0.5 didn't.

comment:3 Changed 3 years ago by timo

  • Resolution set to fixed
  • Status changed from new to closed

(In [15281]) Fixed #15133 - Some markup issues in the docs; thanks Aryeh Leib Taurog for the report.

comment:4 in reply to: ↑ 2 Changed 3 years ago by Aryeh Leib Taurog <vim@…>

Replying to russellm:

Confirmed; this appears to be a recent change, because Sphinx 1.0.7 reports the error, but Sphinx 1.0.5 didn't.

I suspected as much; I started seeing the error on Jan 16, the day after Sphinx 1.0.7 was released, but the django svn log didn't show any recent changes to the offending lines. I guess this is one hazard--or benefit--of a build script which installs the latest sphinx afresh each time it runs.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.