Code

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#151 closed defect (fixed)

javascript clock not dismissed by clicking "cancel"; several references to ljworld.com in the src code

Reported by: Davide Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by adrian)

While going through part 2 of the tutorial (web admin interface), I tried to click on the "Time published" clock" image. The "cancel" row does not appear to dismiss the pop up window. (OTOH clicking on "cancel" on the calendar widget correctly dismisses the calendar popup). I also saw a message on the browser status bar saying "transferring data from media.ljworld.com..."

Looking at the source code I noticed that there are indeed several refs to media.ljworld.com:

[davides@icarus django]$ pwd
/localstore/computer/davides/tmp/django_src/django
[davides@icarus django]$ find . | xargs grep 'media.ljworld.com'
./conf/admin_media/js/.svn/text-base/SelectFilter2.js.svn-base:        quickElement('img', filter_p, '', 'src', 'http://media.ljworld.com/img/admin/selector-search.gif');
./conf/admin_media/js/.svn/text-base/SelectFilter2.js.svn-base:        quickElement('img', selector_filter, '', 'src', 'http://media.ljworld.com/img/admin/selector-add.gif', 'alt', 'Add');
./conf/admin_media/js/admin/.svn/text-base/add_calendars.js.svn-base:                           quickElement('img', cal_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_calendar.gif', 'alt', 'Calendar');
./conf/admin_media/js/admin/.svn/text-base/DateTimeShortcuts.js.svn-base:        quickElement('img', clock_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_clock.gif', 'alt', 'Clock');
./conf/admin_media/js/admin/.svn/text-base/DateTimeShortcuts.js.svn-base:        quickElement('img', cal_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_calendar.gif', 'alt', 'Calendar');
./conf/admin_media/js/admin/add_calendars.js:                           quickElement('img', cal_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_calendar.gif', 'alt', 'Calendar');
./conf/admin_media/js/admin/DateTimeShortcuts.js:        quickElement('img', clock_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_clock.gif', 'alt', 'Clock');
./conf/admin_media/js/admin/DateTimeShortcuts.js:        quickElement('img', cal_link, '', 'src', 'http://media.ljworld.com/img/admin/icon_calendar.gif', 'alt', 'Calendar');
./conf/admin_media/js/SelectFilter2.js:        quickElement('img', filter_p, '', 'src', 'http://media.ljworld.com/img/admin/selector-search.gif');
./conf/admin_media/js/SelectFilter2.js:        quickElement('img', selector_filter, '', 'src', 'http://media.ljworld.com/img/admin/selector-add.gif', 'alt', 'Add');

This is with revision 291.

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by adrian

  • Description modified (diff)

Made a small change to the description to fix formatting.

comment:2 Changed 9 years ago by jacob

  • Resolution set to fixed
  • Status changed from new to closed

The cancel part is fixed in [300]; the ljworld stuff is a duplicate of #49, so I'm marking this fixed.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.