Opened 5 years ago

Closed 5 years ago

#15086 closed (invalid)

Django 1.2.4 on FreeBSD serious error

Reported by: crow16384@… Owned by: nobody
Component: Core (Other) Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi, dear!
First of all - thanks a lot for your work!
I have updated django from 1.2.3 (FreeBSD) to 1.2.4 and now I have a serious error (returned to 1.2.3 version)
I have model and when this model save data, post_save signal creates some other models. When I do it in shell like pp = MyModel(....), pp.save() - all fine,
but when I do it in form like MyForm.save() I have a trouble - records are doubled. In 1.2.3 django all worked fine.

If you need more info please let me know.

Best Reagards,
Crow16384

Attachments (1)

bug_sample.tar.gz (7.4 KB) - added by crow16384 5 years ago.
sample files to show problem

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

There isn't anywhere near enough detail here to consider this a bug report. You haven't even told us what error you are getting -- just that it is "serious".

Closing invalid; if you want us to take this report seriously, you need to provide a reproducible test case. If you can do so, feel free to reopen.

Changed 5 years ago by crow16384

sample files to show problem

comment:2 Changed 5 years ago by crow16384

  • Resolution invalid deleted
  • Status changed from closed to reopened

Many thanks for your attention!

Yes, You are wright, my explanation is not enough.
I did a small sample (in attachment), to show the problem.
After some days and rest ... I understand that problem is in signals.
Running sample you will see, that records could be doubled because one function is connected twice in
signals. I did a stupid example, but the problem exists. It would be very nice to have no possibility
to connect one function twice in one socket (gtk style, if you allow me). Please let me know, I will give you a sample files.

Thanks for your django. It's a game stone.

Best Regards,
crow16384

comment:3 Changed 5 years ago by lrekucki

  • Component changed from Forms to Core framework
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
Back to Top