Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15004 closed Uncategorized (fixed)

Fix for Django Tutorial (part 2), getting admin-site show CSS correctly with development server

Reported by: psgg1981 Owned by: nobody
Component: *.djangoproject.com Version:
Severity: Normal Keywords: tutorial
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hi Django team,

I'm having a lot of fun with Django's tutorial, thanks for sharing!

I must confess I did have a lot of work to understand why and how the admin-site didn't show any css as shown in the tutorial (when using default development server). I looked into a lot of forum posts and web sites and none of them returned a complete answer to my issue. So I've decided to write to you about the fix I think you should include in part 2. The complete step-by-step resolution is available in Django User Groups at https://groups.google.com/d/topic/django-users/UKIyg2RSltM/discussion

Let me know what you think, I hope it'll help any newcomer as well.

Cheers,
Pedro

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by jezdez

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Are you using Django 1.3-beta1?

comment:2 Changed 3 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce the problem, and the linked discussion points to a conversation about configuring apache -- it's not a step-by-step resolution for a problem with the default development server as described.

I'm going to assume that this was caused by Windows permission problems, and that it has been resolved by r15119. Please reopen if the problem hasn't been resolved or you can provide more (or more accurate) details.

comment:3 Changed 3 years ago by rk.aranas@…

  • Easy pickings unset
  • Has patch unset
  • Severity set to Normal
  • Type set to Uncategorized
  • UI/UX unset

Encountered the same problem. Am on Windows XP and using the Django 1.3 that came with the DjangoStack installer by Bitnami. It seems Django couldn't find the media files. Fixed it by creating a /static/admin/media directory inside the polls app directory and placing the contents of /django/contrib/admin/media there.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.